Categories R&S

IPv6 – Routing – EIGRPv6

In this post I will have a look at EIGRPv6 for IPv6.

We will finish the configuration of our network, the goal is to get full reachability between all the devices and hosts.

 

IPv6 – Routing – EIGRPv6 – Network diagram

IPv6 – Routing – EIGRPv6

 

IPv6 – Routing – EIGRPv6 – Configure EIGRPv6:

We are now going to configure EIGRP between R5 and SW5.

There is a couple of different command to enable EIGRP for IPv6.

Not sure which one is the most “proper” but I’d like to use the EIGRP named mode.

 

Let’s configure it on R5 first.

R5(config)#router eigrp EIGRP-100
R5(config-router)#address-family IPV6 autonomous-system 100
R5(config-router-af)#eigrp router-id 5.5.5.5

After configuring this, it looks like all the interfaces had eigrp running on it.

R5#sh ipv6 eigrp interfaces
EIGRP-IPv6 VR(EIGRP-100) Address-Family Interfaces for AS(100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/0                    0        0/0       0/0           0       0/0            0           0
Et0/1                    0        0/0       0/0           0       0/0            0           0
Et0/2                    0        0/0       0/0           0       0/0            0           0

I couldn’t figure out a way to remove them from the EIGRP process, so I will at least make them passive.

R5(config-router-af)#af-interface Eth 0/1
R5(config-router-af-interface)#passive-interface
R5(config-router-af-interface)#af-interface Eth 0/0
R5(config-router-af-interface)#passive-interface

Well it looks good now, I only see the interface to SW5.

R5(config-router-af-interface)#do sh ipv6 eigrp int
EIGRP-IPv6 VR(EIGRP-100) Address-Family Interfaces for AS(100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/2                    0        0/0       0/0           0       0/0            0           0

Here is the detail of the show ipv6 protocol command.

R5#sh ipv6 proto
IPv6 Routing Protocol is "eigrp 100"
EIGRP-IPv6 VR(EIGRP-100) Address-Family Protocol for AS(100)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
  Metric rib-scale 128
  Metric version 64bit
  NSF-aware route hold timer is 240
  Router-ID: 5.5.5.5
  Topology : 0 (base)
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1
    Total Prefix Count: 3
    Total Redist Count: 0

  Interfaces:
    Ethernet0/2
    Ethernet0/1 (passive)
    Ethernet0/0 (passive)
  Redistribution:
    None

We can see the EIGRP name, AS number,  K values …

 

Let’s configure it on SW5. I will use the standard way.

SW5(config)#ipv6 router eigrp 100 
SW5(config-rtr)#eigrp router-id 55.55.55.55

SW5(config)#int Ethernet0/0
SW5(config-if)#ipv6 eigrp 100

And here we go, R5 and SW5 are now EIGRP neighbor.

R5#sh ipv6 eigrp neigh
EIGRP-IPv6 VR(EIGRP-100) Address-Family Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Et0/2                    10 00:00:58    5   100  0  3
    FE80::A8BB:CCFF:FE00:F00

Now I add  the interface vlan 50 and 51 in the EIGRP process.

SW5(config)#int vlan 50
SW5(config-if)#ipv6 eigrp 100
SW5(config-if)#int vlan 51
SW5(config-if)#ipv6 eigrp 100
SW5(config-if)#exit
SW5(config)#ipv6 router eigrp 100
SW5(config-rtr)#passive-interface vlan 50
SW5(config-rtr)#passive-interface vlan 51

R5 now see the routes to the interface vlan 50 and 51.

R5#sh ipv6 route eigrp
IPv6 Routing Table - default - 18 entries
D   2001:DB8:30:10::/64 [90/1029120]
     via FE80::A8BB:CCFF:FE00:F00, Ethernet0/2
D   2001:DB8:30:11::/64 [90/1029120]
     via FE80::A8BB:CCFF:FE00:F00, Ethernet0/2

 

IPv6 – Routing – EIGRPv6 – Configure OSPF/EIGRP redistribution:

It’s now time to redistribute EIGRP into OSPF and vice versa.

This redistribution will happen on R5.

 

Here is the configuration for it.

R5(config)#router eigrp EIGRP-100
R5(config-router)#address-family ipv6 unicast autonomous-system 100
R5(config-router-af)#topology base
R5(config-router-af-topology)#redistribute ospf 10 metric 1000 1 255 1 1500

R5(config)#router ospfv3 10
R5(config-router)#address-family ipv6 unicast
R5(config-router-af)#redistribute eigrp 100

As you can see for both protocols the redistribution is configured under the address-family.

Let’s verify.

On SW5, I received all the routes, they are seen as EX for EIGRP external.

SW5#sh ipv6 route
IPv6 Routing Table - default - 18 entries
EX  2001:DB8:1::/126 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:1::4/126 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:1::8/126 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
D   2001:DB8:1::C/126 [90/307200]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
D   2001:DB8:1::10/126 [90/307200]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:1::14/126 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:1::18/126 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:10:2::/124 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:10:10::/64 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:10:11::/64 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0
EX  2001:DB8:10:12::/64 [170/2611456]
     via FE80::A8BB:CCFF:FE00:520, Ethernet0/0

And on R1, I see the two routes coming from SW5 as OSPF external.

R1#sh ipv6 route
IPv6 Routing Table - default - 17 entries
OE2 2001:DB8:30:10::/64 [110/20]
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/1
OE2 2001:DB8:30:11::/64 [110/20]
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/1

From a host in vlan 10, I can also ping host in vlan 50.

PC13#ping 2001:DB8:30:10:A8BB:CCFF:FE00:1000
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:30:10:A8BB:CCFF:FE00:1000, timeout is 2 seconds:                              
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/20/95 ms
PC13#traceroute 2001:DB8:30:10:A8BB:CCFF:FE00:1000
Type escape sequence to abort.
Tracing the route to 2001:DB8:30:10:A8BB:CCFF:FE00:1000
  1 2001:DB8:10:10::1 6 msec 1 msec 0 msec
  2 2001:DB8:10:2::1 1 msec 1 msec 1 msec
  3 2001:DB8:1::15 2 msec 4 msec 2 msec
  4 2001:DB8:1::F 3 msec 7 msec 7 msec
  5 2001:DB8:30:2::7 4 msec 2 msec 2 msec
  6 2001:DB8:30:10:A8BB:CCFF:FE00:1000 4 msec 10 msec 3 msec

 

IPv6 – Routing – R4 configuration:

In order to obtain full reachability, we need to finish the configuration on R4.

Here we will only redistributed the connected network in to OSPF.

R4(config)#router ospfv3 10
R4(config-router)#address-family ipv6 unicast
R4(config-router-af)#redistribute connected

We can see R1 is receiving the routes from R4.

R1#sh ipv6 route
OE2 2001:DB8:20:10::/64 [110/20]
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/1
     via FE80::A8BB:CCFF:FE00:210, Ethernet0/0
OE2 2001:DB8:20:11::/64 [110/20]
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/1
     via FE80::A8BB:CCFF:FE00:210, Ethernet0/0

 

We now have full reachability between all host and devices.

I hope you found those IPv6 posts informative.

I will come back to some more IPv6 details in a couple of weeks.

 

Thank you for reading.

 

 

IPv6 – Routing – EIGRPv6

Leave a Reply

Your email address will not be published.