Categories R&S

L3 technologies – EIGRP – Initialization

Here is my next CCIE series about EIGRP.
In this first post, I will have a look on the basic EIGRP configuration.

 

This is the link to the Cisco configuration guide for EIGRP:

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_eigrp/configuration/15-mt/ire-15-mt-book/ire-enhanced-igrp.html

 

L3 technologies – EIGRP – Initialization –Network diagram

L3 technologies – EIGRP - Initialization

 

L3 technologies – EIGRP – Initialization – Basic configuration:

Let’s first start EIGRP between R1, R2 and R3.

The loopbacks should also be advertise by EIGRP so we will include them.

Here is the configuration on R1.

R1(config)#router eigrp 10
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 10.10.1.1 0.0.0.0

 

EIGRP is now initialized on R1. Interface loopback0 and Eth0/0 are part of the process.

Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(10)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 192.168.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    10.10.1.1/32
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

R1#sh ip eigrp int
EIGRP-IPv4 Interfaces for AS(10)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                      0        0/0       0/0           0       0/0            0           0
Et0/0                    0        0/0       0/0           0       0/0            0           0

 

I’m configuring R2 and R3 the same way.

R1 now see R2 and R3 as EIGRP neighbor.

R1#sh ip eigrp neigh
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.10.1.3               Et0/0                    10 00:00:30    4   100  0  6
0   10.10.1.2               Et0/0                    10 00:00:59    8   100  0  5

 

L3 technologies – EIGRP – Initialization – Named Mode:

EIGRP named mode is the “new” command to enable EIGRP.

We will start EIGRP on R4 and R5 using named mode.

R4(config)#router eigrp CISCO
R4(config-router)#address-family ipv4 unicast autonomous-system 10
R4(config-router-af)#network 192.168.1.0 0.0.0.255
R4(config-router-af)#network 10.10.14.2 0.0.0.0
R4(config-router-af)#network 10.10.42.1 0.0.0.0
R4(config-router-af)#network 10.10.45.1 0.0.0.0

 

Same on R5.

Now we have an adjacency between R4, R5 and the rest of the routers.

R4#sh ip eigrp neigh
EIGRP-IPv4 VR(CISCO) Address-Family Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.10.45.2              Et0/1                    10 00:03:10   14   100  0  12
0   10.10.14.1              Et0/0                    14 00:04:09    6   100  0  30

 

Note that with this IOS version, auto-summary is disable by default.

Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(CISCO) Address-Family Protocol for AS(10)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    NSF-aware route hold timer is 240
    Router-ID: 192.168.1.4
    SNIP
  Automatic Summarization: disabled

 

L3 technologies – EIGRP – Initialization – Updates:

 

When we turn on the “debug ip packet detail”, we can see that EIGRP is sending updates and other information to the multicast address 224.0.0.10.

IP: s=10.10.14.1 (local), d=224.0.0.10 (Ethernet0/2), len 60, sending broad/multicast, proto=88
IP: s=10.10.14.1 (local), d=224.0.0.10 (Ethernet0/2), len 60, sending full packet, proto=88
IP: s=10.10.1.2 (Ethernet0/0), d=224.0.0.10, len 60, rcvd 0, proto=88
IP: s=10.10.14.2 (Ethernet0/2), d=224.0.0.10, len 60, rcvd 0, proto=88
IP: s=10.10.1.3 (Ethernet0/0), d=224.0.0.10, len 60, rcvd 0, proto=88

 

If we force the neighbor relationship, then it send unicast packets.

R1(config)#router eigrp 10
R1(config-router)#neigh 10.10.14.2 eth0/2
IP: s=10.10.14.1 (local), d=10.10.14.2 (Ethernet0/2), len 60, sending, proto=88
IP: s=10.10.14.1 (local), d=10.10.14.2 (Ethernet0/2), len 60, sending full packet, proto=88

 

EIGRP updates are sent as multicast and if the retransmission timeout is expired before a neighbor ACK the update, it resends them as unicast.

 

L3 technologies – EIGRP – Initialization – Split Horizon:

 

Split horizon is enable by default on all interfaces.

Split horizon blocks route information from being advertised by a device out of any interface from which that information originated.

 

We will have a look later on its effect with EIGRP.

 

 

Well that’s all for this first part about EIGRP.

In the next post we will have a look at EIGRP authentication.

 

Here is a nice post about EIGRP basics:

http://blog.ine.com/2011/01/03/basics-eigrp/

 

Thank you for reading.

 

 

L3 technologies – EIGRP –  Initialization

Leave a Reply

Your email address will not be published.