Categories R&S

L3 Technologies – EIGRP – Summarization

In this post I will have a look at the different ways to perform route summarization with EIGRP.

 

Here is the link to the Cisco documentation about EIGRP summarization:

Cisco EIGRP IOS 15.3 Summarization

 

L3 Technologies – EIGRP – Summarization – network diagram

L3 Technologies – EIGRP - Summarization

 

L3 Technologies – EIGRP – Summarization – Theory:

By default, auto summary is turned on.

From the Cisco configuration guide:

“Automatic summarization is performed when two or more network router configuration or address family configuration commands are configured for an EIGRP process.”

 

However like with all the routing protocol it is consider best practice to turn off auto summary.

 

L3 Technologies – EIGRP – Manual Summarization:

Manual summarization is performed at the interface level.

Here we will make sure that SW1 is sending a summary route for interfaces vlan 10 and 11 to R1.

 

This is the current routing table on R1.

R1#sh ip route 10.100.10.1
Routing entry for 10.100.10.0/25
  Known via "eigrp 10", distance 90, metric 281856, type internal
  Redistributing via eigrp 10
  Last update from 10.10.11.2 on Ethernet0/1, 00:00:22 ago
  Routing Descriptor Blocks:
  * 10.10.11.2, from 10.10.11.2, 00:00:22 ago, via Ethernet0/1
      Route metric is 281856, traffic share count is 1
      Total delay is 1010 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
R1#sh ip route 10.100.10.129
Routing entry for 10.100.10.128/25
  Known via "eigrp 10", distance 90, metric 281856, type internal
  Redistributing via eigrp 10
  Last update from 10.10.11.2 on Ethernet0/1, 00:00:39 ago
  Routing Descriptor Blocks:
  * 10.10.11.2, from 10.10.11.2, 00:00:39 ago, via Ethernet0/1
      Route metric is 281856, traffic share count is 1
      Total delay is 1010 microseconds, minimum bandwidth is 10000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

 

Now on SW1 interface, we apply our summary route.

SW1(config)#int eth 0/0
SW1(config-if)#ip summary-address eigrp 10 10.100.10.0/24

 

On R1, we now get the summary route to 10.100.10.0/24

R1#sh ip route 10.100.10.1
Routing entry for 10.100.10.0/24
  Known via "eigrp 10", distance 90, metric 281856, type internal
  Redistributing via eigrp 10
  Last update from 10.10.11.2 on Ethernet0/1, 00:01:43 ago
  Routing Descriptor Blocks:
  * 10.10.11.2, from 10.10.11.2, 00:01:43 ago, via Ethernet0/1
      Route metric is 281856, traffic share count is 1
      Total delay is 1010 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
R1#sh ip route 10.100.10.129
Routing entry for 10.100.10.0/24
  Known via "eigrp 10", distance 90, metric 281856, type internal
  Redistributing via eigrp 10
  Last update from 10.10.11.2 on Ethernet0/1, 00:01:46 ago
  Routing Descriptor Blocks:
  * 10.10.11.2, from 10.10.11.2, 00:01:46 ago, via Ethernet0/1
      Route metric is 281856, traffic share count is 1
      Total delay is 1010 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

 

On SW1, a new route has been added, a route to null.

D        10.100.10.0/24 is a summary, 00:02:52, Null0

 

This is used to prevent routing loops.

It will drop the traffic if any packet send to an address that belong to the summary doesn’t exist.

 

Here is a nice explanation about this null route and its purpose:

http://keepingitclassless.net/2013/04/the-route-to-null0-is-ok/

 

L3 Technologies – EIGRP – Summarization with Default Routing:

A default route can also be sent the same way.

Let’s sent this summary default route from R4 to SW2.

R4(config)#router eigrp CISCO
R4(config-router)#address-family ipv4 unicast autonomous-system 10
R4(config-router-af)#af-interface Eth 0/2
R4(config-router-af-interface)#summary-address 0.0.0.0 0.0.0.0
%DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 10.10.42.2 (Ethernet0/2) is resync: summary configured

 

Now on SW2, a summary route is received.

SW2#sh ip route
SNIP
Gateway of last resort is 10.10.42.1 to network 0.0.0.0

D*    0.0.0.0/0 [90/281632] via 10.10.42.1, 00:00:23, Ethernet0/0
      10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

 

On R4, we now have a default route to null0.

R4#sh ip route
SNIP
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

D*    0.0.0.0/0 is a summary, 00:00:49, Null0
      10.0.0.0/8 is variably subnetted, 12 subnets, 4 masks

R4(config-router-af-topology)#do sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 5, metric 1280, candidate default path, type internal
  Redistributing via eigrp 10
  Routing Descriptor Blocks:
  * directly connected, via Null0

 

This can be an issue. Because the administrative distance of this route is 5.

It will most likely override any other legitimate default route.

This problem can be solved by using floating summary routes.

Note that because I’m using a IOS 15.4, the distance option is deprecated, so I’ using the summary-metric command.

R4(config-if)#router eigrp CISCO
R4(config-router)#address-family ipv4 unicast autonomous-system 10
R4(config-router-af-interface)#summary-address 0.0.0.0 0.0.0.0
R4(config-router-af-interface)#exit
R4(config-router-af)#topology base
R4(config-router-af-topology)#summary-metric 0.0.0.0 0.0.0.0 distance 254

 

By configuring the administrative distance of our summary route to 254, we make sure that this route to null does not take over any legitimate default routes.

R4#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 10", distance 254, metric 1280, candidate default path, type internal
  Redistributing via eigrp 10

 

This route to null0 can also be poison by configuring an AD of 255, but in my case this is also suppressing the default route on SW2.

 

L3 Technologies – EIGRP – Summarization with Leak Map:

Leak-map is a technic that will allow some specific routes to be sent even if we have summarization.

We need to use a route-map in combination with an access list or prefix-list (preferred) and the IP range permitted in the access-list or prefix-list will be leak to the device that receive the summary route.

Let’s do this on SW2.

We already receive the summary from R4. Now we want SW2 to receive the route from SW1 interface vlan 10 (10.100.10.0/25). (I have remove the summary on SW1)

R4(config)#ip prefix-list R1_VLAN10 permit 10.100.10.0/25

R4(config)#route-map LEAK-R1_VLAN10 permit 10
R4(config-route-map)#match ip address prefix-list R1_VLAN10

R4(config)#router eigrp CISCO
R4(config-router)#address-family ipv4 unicast autonomous-system 10
R4(config-router-af)#af-interface eth0/2
R4(config-router-af-interface)#summary-address 0.0.0.0 0.0.0.0 leak-map LEAK-R1_VLAN10

 

Now SW2 is getting the default route and this specific route from the leak map.

SW2#sh ip route eigrp
SNIP
Gateway of last resort is 10.10.42.1 to network 0.0.0.0

D*    0.0.0.0/0 [90/281632] via 10.10.42.1, 00:03:21, Ethernet0/0
      10.0.0.0/8 is variably subnetted, 5 subnets, 4 masks
D        10.100.10.0/25 [90/333056] via 10.10.42.1, 00:01:07, Ethernet0/0

 

That’s it about EIGRP summarization.

Next post will be about EIGRP filtering.

 

Thank you for reading.

 

Have a look at my previous L3 Technologies – EIGRP posts:

L3 Technologies – EIGRP – Initialization

L3 Technologies – EIGRP – Authentication

L3 Technologies – EIGRP – Path Selection

 

 

L3 Technologies – EIGRP – Summarization

Leave a Reply

Your email address will not be published.