Categories R&S

VPN Technologies – MPLS-L3VPN – PE-CE routing OSPF EIGRP

In this post, we will connect a new customer (Customer2) to our MPLS backbone.

Router CE21 will be connected to R5 and we will use OSPF as the PE-CE routing protocol.

Router CE22 will be connected to R7 and we will use EIGRP as the PE-CE routing protocol.

 

VPN Technologies – MPLS-L3VPN - PE-CE routing OSPF/EIGRP

 

Here are the links to the Cisco documentation for this:

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l3_vpns/configuration/15-mt/mp-l3-vpns-15-mt-book/mp-vpn-ospf-pe-ce-support.html

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l3_vpns/configuration/15-mt/mp-l3-vpns-15-mt-book/mp-vpn-support-eigrp-betw-pe-ce.html

 

VPN Technologies – MPLS-L3VPN – PE-CE routing OSPF/EIGRP – configuration:

 

VPN Technologies – MPLS-L3VPN – PE-CE routing OSPF:

I configure first the VRF for Customer2 on all of our PE routers and then the interface.

R5(config)#vrf definition CUST2
R5(config-vrf)# address-family ipv4
R5(config-vrf-af)# rd 65102:1
R5(config-vrf)# route-target export 65102:1
R5(config-vrf)# route-target import 65102:1

R5(config)#int Ethernet1/1
R5(config-if)#vrf forwarding CUST2
R5(config-if)#ip add 10.100.2.0 255.255.255.254

 

Same for R7.

For the connection between CE21 and R5, we will configure OSPF as the PE-CE routing protocol.

R5(config)#router ospf 2 vrf CUST2
R5(config-router)#int Ethernet1/1
R5(config-if)#ip ospf 2 area 0

 

We still to configure this customer into MP-BGP and redistribute OSPF into it.

Note that when redistributing OSPF into BGP 9or MP-BGP), by default, only OSPF intra-area and inter-area routes are redistributed into BGP.

Have a look on the link below for more information from Cisco about redistributing OSPF into BGP:

http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/5242-bgp-ospf-redis.html

R5(config-if)#router bgp 65010
R5(config-router)#address-family ipv4 vrf CUST2
R5(config-router-af)#redistribute connected
R5(config-router-af)#redistribute ospf 2 match internal external 1 external 2

 

We also need to redistribute BGP under OSPF.

R5(config)#router ospf 2 vrf CUST2
R5(config-router)#redistribute bgp 65010 subnet

 

And on CE21, we configure basic OSPF.

CE21(config)#router ospf 2
CE21(config-router)#redistribute connected subnets
CE21(config-router)#int Ethernet0/0
CE21(config-if)#ip ospf 2 area 0

 

OSPF neighbor adjacency is UP.

CE21#sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.100.2.0        1   FULL/DR         00:00:34    10.100.2.0      Ethernet0/0

 

VPN Technologies – MPLS-L3VPN – PE-CE routing EIGRP:

For the connection between CE22 and R7, we will configure EIGRP  as the PE-CE routing protocol.

R7(config)#router eigrp CUST2
R7(config-router)#address-family ipv4 vrf CUST2 autonomous-system 2
R7(config-router-af)#network 10.100.2.2 0.0.0.0
R7(config-router-af)#topology base
R7(config-router-af-topology)#redistribute bgp 65010 metric 10000 100 255 1 1500

 

Next, we configure MP-BGP.

R7(config)#router bgp 65010
R7(config-router)#address-family ipv4 vrf CUST2
R7(config-router-af)#redistribute connected
R7(config-router-af)#redistribute eigrp 2

 

On CE22, we configure EIGRP.

CE22(config)#router eigrp CUST2
CE22(config-router)#address-family ipv4 unicast autonomous-system 2
CE22(config-router-af)#network 10.100.2.3 0.0.0.0
CE22(config-router-af)#topology base
CE22(config-router-af-topology)#redistribute connected metric 10000 100 255 1 1500

 

EIGRP adjacency is UP.

EIGRP-IPv4 VR(CUST2) Address-Family Neighbors for AS(2)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.100.2.2              Et0/0                    13 00:01:28    8   100  0  3

 

From CE21, we are now able to ping CE22 loopback.

CE21#ping 192.168.22.1 so lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.22.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.22.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

 

We now have two different customers going over the same MPLS network and they are totally isolated.

I can keep adding new location or new customer using the same method.

On my side I find it much easier to use BGP as the PE-CE protocol but depending on the type of router used as a CE you might have no other choice that using OSPF or EIGRP.

 

 

Thank you for reading.

 

Have a look at my previous VPN Technologies posts:

VPN Technpologies – MPLS – Label Distribution Protocol

VPN Technpologies – MPLS-L3VPN – MP-BGP

VPN Technpologies – MPLS-L3VPN – PE-CE routing

 

 

 

VPN Technologies – MPLS-L3VPN – PE-CE routing OSPF EIGRP

Leave a Reply

Your email address will not be published.